2026 Panora Connect - A Evercore Corporation Project.
Resolved
Service has been restored and the incident is resolved.
Investigating
We are currently experiencing a service disruption affecting authentication and other platform features. This is caused by an ongoing worldwide outage with Discord, which we rely on for core functionality.
Our team is actively monitoring the situation. No action is required on your end. We will provide updates as Discord restores service.
We apologize for the inconvenience.