2026 Panora Connect - A EVERCORE TECHNOLOGIES INCORPORATED Project.
Monitoring
We have pushed out a half-fix to the workspace icons failing to render. Our Discovery page is the last page affected by this issue and will be fixed later today.
Identified
We are rolling out icon refreshes in groups. All affected workspaces should be fixed by 1:50 am ET.
Identified
We've found the source of the disruption and our engineers are already deploying the solution.
Investigating
Some workspaces are missing images. Our team is now aware of an issue and is actively investigating.